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Basics of ArcGIS Pro (A Hands-On Exercise) 
 
Introduction 

This exercise is designed to introduce you to GIS software and data, or to refresh your memory if 
it has been awhile. We will go through some of the most basic aspects of GIS, including creating 
a project file, connecting data, joining tables, and making a simple map of commuting patterns in 
the Upper Valley. We recommend that you go through the video lectures and quizzes first to 
understand the concepts discussed here.  

Please review the most fundamental aspects of GIS: 

• Read the instructions carefully and follow them precisely- most questions you have 
will be answered in the handout itself 

• SAVE YOUR WORK FREQUENTLY and back up your project and data (ArcGIS, 
while very useful, is finicky and known for crashing unexpectedly, at the worst possible 
times  ) 

• Never use spaces, special characters, or dashes in folder names or file names (e.g., 
don’t save your files into the “My Documents” folder, or name your folder as “Your 
Name GIS Project” with spaces). Underscores_ are ok. The computer will interpret 
spaces and special characters as a command, and potentially give mysterious errors when 
running tools. 

• A shapefile is a collection of files, not a single file: the most basic vector data form, a 
shapefile, might include anywhere from 4-8 files, including the file extensions *.shp, 
*.dbf, *.shx, *.prj, etc. It is best to move, delete, and rename these files within a GIS 
software rather than a file explorer, since GIS software recognize these as a single dataset 
and will move them together. 

• Each time you open up a GIS project file, you may need to check that layer paths 
are correctly mapped. GIS project files do not actually contain the layers (shapefiles, 
raster images, etc.) that make up the map; instead, it links to where those data layers are 
saved on your computer and simply displays them. If you move or rename your data, then 
reopen your project file, the software will no longer know where they are located and ask 
you to relink them. There is a handout on Canvas going through the process of relinking 
data to your project. 

• Getting Help: Learning how to solve your own problems is the most valuable skill in 
GIS. Please try problem-solving independently or with a buddy (or group). Google is the 
#1 tool for learning GIS, and websites like Stack Exchange, Esri, or ArcGIS Pro are full 
of users asking similar questions and providing answers. But we are also here to help!   
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PART A: 

1. Set up your working folder on the lab computer 
 

a. Log in to your lab computer with your netID and password (not the public user this time… if 
you are stuck as another user, click ‘Other User’ at the bottom left of the screen).  
 

b. Create a working folder on the computer to store your GIS project file and 
all data input and output files. At the bottom of the screen, click on the 
File Explorer: . Click on ‘This PC’ at the left, then double-click on the 
Data (D:) drive, since it has more storage.  

 

c. Create a new folder somewhere on this drive (right-click, New → Folder), and rename it with 
your first name and last name(s). If your name is very long, you might abbreviate. 
Remember: there cannot be spaces or special characters in your folder name! Replace the 
space with an underscore. 
 

2. Download and prepare the lab data 
 

a. The data for this exercise are located on the Geospatial Hub website. Download the file 
called Basic_Exercise_Data.zip. This is a collection of files that have been compressed (or 
zipped) together, allowing multiple files to be transferred between computers in an efficient 
way. Importantly: you will not be able to use or edit these zipped files until they are 
unzipped, or extracted. This is a very common mistake in working with GIS software.  
 

b. Right click on the zip file’s name in Downloads and select ‘Extract All’. For the destination, 
click ‘Browse’ and navigate back through the computer to your working folder (This PC → 
Data (D:) drive → YourName). Click once on your working folder’s name, then hit ‘Select 
Folder’ and ‘Extract’. 
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3. Set up your ArcGIS Pro Project 

 
a. Search the computer for ‘ArcGIS Pro’ and 

open the software. Our licensing for the 
software has changed, so you will need to 
sign in with your ArcGIS Online account 
every time to open it. Expand ‘Your ArcGIS 
organization’s URL’, then type in dartmouth 
and check the box next to ‘Remember this 
URL’. Click on the blue Dartmouth College 
box, then log in with your netID. 
 

b. Under new project, select Map. Rename the 
project something reasonable. For the 
location, click on the folder icon and 
manually navigate to your new 
YourName working folder.  
 

c. A new project file should now open. An 
ArcGIS Pro project file is made up of 
multiple components: 

 

Figure 1: Esri. 

 
d. See the image on the next page to learn/remember the terminology of different components 

of the project file. If you are missing one of these panes, go to the View tab → Windows 
group → Reset panes for mapping (default). 
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e. Test your knowledge: making sure you’re in the Map tab of the upper ribbon, go to the Layer 

group, click on the Basemap button, and try changing the basemap for your map canvas. 
 

4. Connect Data to the ArcGIS Project 
 

a. Look at the Catalog pane of your project. This is where all your maps, layouts, toolboxes, 
and data can be opened. If you ever accidentally close the Map tab and lose your Map 
Canvas, you can find it under the Maps section. The Folders section allows you to connect 
your GIS software to other folders on your computer. Expand the arrow next to its name. 
Right now, you should only see your working folder, the folder with your name that you 
created earlier, with a home icon.  
 

b. Next, you can add a connection to the data folder that was downloaded onto your computer. 
Right-click on Folders and select Add Folder Connection. Browse through your computer 
files to your working folder → Basic_Exercise_Data. Click once on its folder and click OK. 
You should see a new folder connection for Basic_Exercise_Data, under your other 
connection. 

 
c. Open the data folder and look inside. You should see two shapefiles from the US Census 

called NH_CensusTracts and VT_CensusTracts, and two tables (CSV format) for commuting 
characteristics. Right-click both shapefiles and add to your current map. 

 
d. You should see polygons (Census tracts) for NH and VT added to your map. In your 

Contents pane at left, you should now see the two shapefile names showing up. They should 
be at the top of the list, meaning that they are the first items drawn on the map. If you were to 
click and drag one under your basemap layers (called something like World Topographic 
Map and World Hillshade, but might be different depending on which you selected), what 



Department of Geography  Page: 5/10 
 

would happen?  
 

e. The spatial part of the dataset doesn’t tell us much information on its own. Right-click one of 
the census tract layers and go to Attribute Table. A table should open at the bottom with 
attribute information about these polygons. There are many fields containing different codes, 
and values for amount of land or water within each polygon (ALAND, etc.). We will need to 
add more information. 

 
5. Join the Data to External Tables 
 
For this exercise, we will want to make a map showing commuting patterns. To get this 
information, we will need to use the relational database aspect of GIS by joining the shapefile 
with the two external tables.  

a. Add the two CSV tables for NH and VT to your current map. You should see their names 
appear under ‘Standalone Tables’, but nothing in the map (this makes sense- they do not 
contain spatial data!).  
 

b. Right-click the NH CSV name and Open. You should see one field ‘GEOID’, which contains 
the ID number of each block polygon, and other fields describing the number of workers 
within each tract and whether they drive alone or carpool.   

 
c. Compare the NH CSV table to the NH shapefile attribute table. To join them, you will need 

to find a field with identical values within both tables to use as the linking key. Which fields 
will be used as the linking key? 

 
d. Hover your cursor over one of the linking key fields until a message pops up. What are the 

data types of these fields? Do the same for the VT CSV and VT shapefile too (hint: they 
should be the same as NH).  

 
e. You should have found that the linking key in the census tract shapefiles has a different data 

type than your CSVs. If you try to join them without fixing this, you will not be successful. 
Instead, we can add a new field with the proper data type and copy those values into it. In the 
attribute table for the NH shapefile, click the Add Field button. Add a new field to the table 
called ID_INT (for ID integer) and make sure it is the data type Long. 

 

 
 

f. Click on the Save Edits button on the upper ribbon, then close the Fields window.  
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g. Scroll all the way to the right of the NH census 
tracts attribute table. You should see the new 
field at the very end, filled with 0s. Right-click 
on the field name and open the Field Calculator 
(select Calculate Field).  
 

h. To copy values from another field, scroll down 
in the list under Fields until you see STFID. 
Double-click on the name STFID. This should 
cause the textbox under the menu, beneath 
“ID_INT =” to be filled with !STFID!. The 
exclamation points tell the computer to read this 
as a field name from the dataset. Click OK. This 
field should now be populated with values. 

 
i. Repeat the same steps to copy over ID values 

into a new integer field in the VT census tract 
shapefile. 

 
j. Now that the IDs match, we can join the data. 

Right-click on the NH census tract shapefile and 
go to Joins and Relates → Add Join. When you 
join, you will always want to start from the spatial dataset- otherwise you will lose all 
geometry. 

 
k. The input table should already say 

NH_CensusTracts. Set the Join 
Table to its corresponding CSV. 
The computer will try to guess at 
which field you will use as the 
linking key, but make sure these 
match with the values you recorded 
in step c. Ignore any yellow 
warning icons, click Validate Join, 
and scroll to the bottom. If the join 
will work, it should say something 
like the following:  

 
l. If the join looks good, click OK and you should see new fields added to your shapefile’s 

attribute table. It’s okay if one value is null, but the majority of the records should contain 
values.  

 
m. Repeat the same process to join the VT CSV to the VT shapefile.  

 
n. Now that you have successfully joined tables to both your shapefiles, you will need to make 

the join permanent. Remember that otherwise the computer will read this as two separate 
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datasets (the shapefile + CSV) and will result in errors if you try to use any tools on it. Right-
click on the NH census tract shapefiles and go to Data → Export Features. Give it a name 
like NH_Census_Join and save it into your YourName folder.  

 
o. Repeat the same process on the VT census tract shapefile. When finished, remove the 

original layers so you are only left with the joined shapefiles (right-click the layer’s name in 
Contents and Remove).  

 
6. Align Coordinate Systems and Projections 

 
a. You may have noticed that your VT and NH shapefiles look quite stretched and fat on the 

map. Right-click on Map in your Contents pane and go to Properties → Coordinate Systems. 
The current coordinate system for this project should be NAD 1983 (the North American 
Datum). Note that this is just a datum; it is a three-dimensional system, not yet projected! 
 

b. For this lab, we will use the projected coordinate system NAD 1983 UTM Zone 19N. For 
future labs, we will use a more specific PCS for the Upper Valley. Type the whole name of 
this coordinate system into the search bar and hit enter. You should see a caret next to 
Projected Coordinate System: expand that, then keep expanding until you see its full name 
with a gray globe icon. Click once on this, then click OK. 

 
c. Your map should change in shape, reducing the distortion on both states. It may also rotate 

slightly to keep the study area in the middle of the map. This means that our map has been 
projected. Open the map properties → Coordinate Systems again and look at the top under 
the Layers heading. Expand the carets next to NAD 1983 and WGS 1984 Web Mercator.  

 
d. Even though your map is now in NAD 1983 UTM Zone 19N, and looks undistorted, your 

data files are still in NAD 1983. This is a process called projection on the fly- your computer 
notices a discrepancy in your map and data and performs some temporary calculations to 
align your data with the map. Note that this doesn’t actually change the coordinates 
themselves- they are still in units of degrees- but makes it visually appear as though it is in 
the UTM projection. We need to perform coordinate transformation in order to make both the 
data and map align. 

 
e. Make sure your map is still set to UTM Zone 19N, then go to the Analysis 

tab → Tools icon. This opens the Geoprocessing pane at right, which 
contains all the different tools of ArcGIS. Search for “Project”, a tool which 
will mathematically transform your coordinates from one coordinate system 
to another. Click once on the tool name to open it. 

 
f. In the tool window, set the input dataset to be the NH_CensusTracts_Join. Save the output 

dataset into your folder by clicking on the folder icon and browsing to its location, then name 
it NH_CensusTracts_Projected. The output coordinate system can be set to current map, 
which should be UTM Zone 19N. Run the tool. 
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g. Repeat the same process to project the joined VT census tract shapefile. Remove the old 
layers. 

 
7. Visualize the Data 
 
To display the new commuting information on the map, we will need to update the symbology of 
the two census tract layers.  

a. Right-click on NH_CensusTracts_Projected and go to Symbology. The primary symbology 
is set to single symbol, which will display all polygons with the same color and outline. 
Change this dropdown menu to say Graduated Colors, 
also known as a choropleth map. This will group data 
into classes based on values from a field. Change the 
dropdown menu next to Field to say Total_Work, which 
should look something like the left screenshot 
 

b. Note the spatial pattern of workers in New Hampshire- 
most are concentrated around the urban areas, which is to 
be expected. Note also the varying sizes of the polygons: 
census tracts in rural areas tend to be larger than those in 
urban areas. This can influence people’s perceptions of 
spatial trends, as it seems like the larger areas are more 
important, even though the smaller census tracts usually 
have more population. We usually show raw counts (total population, etc.) as graduated 
symbols rather than graduated color (screenshot at right). 
 

c. To be more realistic, we might choose to show commuting as 
a rate of the total population. We could do this by adding a 
new field to the attribute table and calculating it, but since we 
just want a simple visual fix, we can change the symbology 
directly. Change the Field dropdown to say Drive_Alone, and 
then change the Normalization dropdown to Total_Workers. 
This will visualize the percentage of total workers who 
commute by driving alone.  
 

d. You may see some missing polygons, which don’t have any 
commuting information from the census. Ignore those for now. 
Click on the Histogram tab at the bottom to see a distribution 
of values within this field. You can change how the data are 
classified by switching the Method from Natural Breaks to 
something else- read through the descriptions to see what the 
differences are. You can also change the number of classes to 
get more or less variation (usually 4-8 is a reasonable number), 
or switch the color scheme. 

 
e. Make sure that the color scheme and class breaks are the same 

for both the NH and the VT layers. You can manually edit the 
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class breaks by double-clicking into the upper value boxes under the Classes tab. You should 
also double-click into the label boxes and change to be percentages (e.g. type in “38 – 63%”, 
rather than 0.38 – 0.63). You only need to do this for one of the data layers, not both. Do not 
worry if your values are different from the screenshot- they likely will be! 
 

8. Create a Simple Map 
 

To showcase your findings, you will create a simple map.  

a. Add the data layer Study_Area_Polygon from your data 
folder. Open its Symbology and leave the primary 
symbology as single symbol. Click on the symbol patch 
to open a window with options. You can either pick one of the symbols in the gallery, or go 
to the Properties tab and manually change the fill and outline color. Update the symbology to 
have transparent fill but a bold outline around the Upper Valley boundary. 
 

b. When creating a map, it’s best to make a layout so you can add text for the title and a legend. 
Go to the Insert tab → New Layout → ANSI- Landscape Letter 8.5” x 11”. A layout window 
will open with a blank sheet of paper. It will only print what is on the white space of the 
layout. 

 
c. In the Insert tab, click on Map Frame, then select the image of the map that matches what 

you just created. Click and drag to add it to your layout, like drawing a text box.  
 

d. We might want to visually mask out data outside of the Upper Valley boundary. We could 
use the tool Clip to manually cut out the data if we needed it for analysis, but since this is just 
visual, you can right-click on your Map name in Contents → Clip Layers → Clip to an 
outline → Get shape from Study_Area_Polygon.  

 
e. You should also make sure there is enough extent from the basemap to show what these 

locations are. If your basemap is not showing any labels, go back to the Map tab and switch it 
to an option that puts labels on top of your data, such as Human Geography. 

 
f. Add a legend by going to the Insert tab → Legend and picking any one of the options. Click 

and drag to draw it on your layout. It should look very chaotic! We can clean it up by 
renaming the layer in the Contents pane. This will not change the underlying data file, just 
how it is symbolized in the project. Right-click on the NH 
or VT layer that is labeled with percent symbols and go to 
Properties → General. Change the name to something 
like “Percentage of Commuters who Commute by 
Driving”. At the top of the Contents pane, under Legend, 
uncheck the boxes for every layer that is not the one you just edited so that there is only one 
item in the legend. 

 
g. In the Contents pane, right-click on Legend and go to Properties. Under the map frame 

dropdown, uncheck the box next to Title: Show. It’s usually best not to label the legend as 
Legend, since that’s intuitive. Click on the Show Properties box. Since the layer name gives 
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all information that we need, we can turn off the labeling for the Drive_Alone/Total_Work 
fields. Uncheck the box next to Headings (if grayed out, make sure only that layer is selected 
in the legend Contents pane).  

 
h. You should also update the font for your project, since the default Tahoma font is pretty 

unpleasant. Do this in the Text Symbol tab. To make your life easier, you might also change 
the entire font settings for the project so it will update on all future maps. Save your project, 
then go to the Project tab → Options → Text and Graphics and change the default font name 
to something you like better (good choices might be Arial, Avenir, Bell MT, whatever looks 
easy to read and professional.). Then click the back arrow at the upper left. You may need to 
save, close, and reopen the project for the change to actually apply. 

 
i. Add a scale bar by going to the Insert tab, clicking on the scale bar button and selecting 

an option (scale bars should not be too fancy and distracting from the rest of the map). 
Click and drag to place it where it won’t be the center of attention. Adjust the scale bar 
size by clicking and dragging the diagonal corners to make the numbers easy to read 
and with logical breaks (e.g., 10 miles rather than 13.482 miles).  

 
j. Add a title to the map by clicking on the Insert tab, then in the Graphics and Text group, 

click on  . Click and drag to draw the textbox. Type in some title that explains what this 
map shows and where it is located (the what and where). Once placed, click on the new tab 
Text in the upper ribbon. Change the size to something reasonable. 
 

9. Export your Map 
 
Finally, you can export your map as a PDF. 

a. Go to the Share tab → Output Group → Export Layout button. Select the Vector PDF option. 
This should open an export window at right. Make sure the name is set to save into your 
overall working folder (e.g. Aletha_Spang) and name it something you will recognize. Leave 
the resolution at 150 DPI and export. 

This completes the hands-on exercise to introduce you to ArcGIS Pro. If you want handouts on 
more advanced analysis or geovisualization topics, check out the Instructional Handout section 
on our Geospatial Hub website. Feel free to reach out with any questions.  


