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Introduction to GIS Software 
(A Hands-On Tutorial with ArcGIS Pro) 

 
Introduction 

This tutorial is designed to introduce you to working with ArcGIS Pro software and spatial data 
(or to refresh your memory if it has been awhile). To access ArcGIS Pro at Dartmouth, check out 
the following page: https://sites.dartmouth.edu/gis-geography/software/ 

Before beginning the exercise, familiarize yourself with foundational GIS concepts, including 
vector vs. raster data models and coordinate systems. We recommend the following learning 
pathway: https://sites.dartmouth.edu/gis-geography/basics-of-gis-training/ 
 

https://sites.dartmouth.edu/gis-geography/software/
https://sites.dartmouth.edu/gis-geography/basics-of-gis-training/
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Outline: 

In this tutorial, you will go through the basics of setting up a workspace on your computer, 
creating an ArcGIS Pro project, navigating the interface, adding data, joining attribute tables, 
calculating rates, and creating a simple map layout showing the distribution of population using 
nutritional assistance programs in New Hampshire and Vermont.   
 
PART A: Introduction to ArcGIS Pro 

1.​ Set up a working folder on your computer 
 

a.​ Log into your computer. If using one of the Rahr Lab machines, use the public user 
account (“Public Cluster Machines” (or Other User → public_user if not an option), leave the 
password box empty and hit enter).   
 

b.​ Create a new folder on the computer to store all your GIS files (there will be a lot!). We refer 
to this as your “working folder”: 

 

●​ If using a Rahr lab computer, click on the File Explorer: , ‘This PC’ at the left, 
then double-click on the Data (D:) drive, which has more storage than the computer’s 
main hard drive (C:). Right-click → New → Folder. 

 

 

●​ If using the remote ArcGIS Pro application through RDS, open the virtual file 
explorer application, navigate to DartFS → your netID folder, and right-click → New 
→ Folder. 

Name the folder something like YourName_GISTutorial. If your name is very long, you 
might abbreviate. Remember: there cannot be spaces or special characters in your folder 
name! Replace any spaces with an underscore. 

2.​ Download and prepare the tutorial data 
 

a.​ The data for this exercise are located on the GIS Learning Hub website in the zip file named 
Intro_GIS_Software_Tutorial.zip. This is a collection of files that have been compressed 
(zipped) together, allowing multiple files to be transferred between computers in an efficient 
way. You will not be able to use or edit these zipped files until they are unzipped. Unlike a 
Mac, you cannot just double-click on the file to unzip it – you need to manually extract it.   
 

b.​ Right-click on the zip file’s name in Downloads and select ‘Extract All’. For the destination, 
click ‘Browse’ and navigate back through the computer to your working folder. Click once 
on your working folder’s name, then hit ‘Select Folder’ and ‘Extract’. 
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3.​ Create a New ArcGIS Pro Project 

 
a.​ Open ArcGIS Pro. Licensing for the software has 

changed, so you will need to sign in with your 
ArcGIS Online account every time. Expand ‘Your 
ArcGIS organization’s URL’, then type in 
dartmouth and check the box next to ‘Remember 
this URL’. Click on the blue Dartmouth College 
box, then log in with your netID. 
 
Note: on public computers, you may become stuck 
in a loop of logging in as another user. If this 
happens, uncheck “Sign in automatically” at the 
bottom left, select ‘Sign in Using Browser’ at the 
bottom right, and wait for the browser to open. 
When prompted, open in ArcGIS Pro.  
 

b.​ Under new project, select Map. Give it a 
reasonable name without spaces or 
special characters, such as 
Intro_GIS_Tutorial. For the location, 
click on the folder icon and manually 
navigate to your new working folder. 
You can either leave the “create new 
folder” option checked or unchecked. 
 

c.​ A new project file should now open. An ArcGIS Pro project is made up of multiple 
components: 

 

Figure 1: Esri. 

 
The project itself is a .aprx file, or an ArcGIS Pro project file. To open the project from your 
file explorer, you would double-click on the following: 
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The other folders and files shown are created by default and necessary for the project to run. 
If you need to share your project, you should share all of these files together.  
 

d.​ Once the ArcGIS Pro project loads, see the image below to learn/remember the interface 
terminology. If you are missing any of these panes, go to the View tab → Windows group → 
Reset panes for mapping (default). 

 
e.​ You may see a different basemap than shown in the screenshot. Test your knowledge: making 

sure you’re in the Map tab of the upper ribbon, go to the Layer group, click on the Basemap 
button, and try changing the basemap for your map canvas. 

 
f.​ The default Dartmouth basemap is called blueprint, and isn’t very informative or 

aesthetically pleasing. You can change this by going to the Project tab → Options → Map 
and Scene → and changing the default basemap option to one you like.  

 
g.​ Take a look at other settings you can change in the options. We recommend waiting until you 

have a better grasp on the software before changing anything, but you can customize the 
software at any time to help your workflow. 
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4.​ Explore the Catalog 
 

a.​ Look at the Catalog pane of your project (on the right). This is where you 
can access all your maps, layouts, toolboxes, and data at any time. Test out 
what happens if you accidentally close out of your map by hitting the x 
above the Canvas. Where would you look to find it? You can open it again 
by right-clicking on its name and selecting Open. 
 

b.​ The Folders section allows ArcGIS to access other folders on your 
computer, but first you will need to manually make a connection. 
Expand the arrow next to Folders; you should only see a default folder 
with your project’s name, which was created when you made a new 
project.  

 
c.​ Expand the arrow next to the geodatabase (.gdb) to look inside. It should be empty if created 

properly. 
 

d.​ Outside of ArcGIS in your file 
explorer, open the geodatabase 
folder (.gdb). What do you see 
inside now? 

 
A geodatabase is essentially a 
“container” that is specially 
designed for storing geographic data: it keeps track of how things connect and relate to each 
other, and allows for faster searching and analysis. Everything you see in the folder are 
“behind-the-scenes” files necessary for its structure. As such, we recommend only adding 
things to the geodatabase or moving files around inside ArcGIS Pro to avoid accidentally 
deleting anything.  

 
e.​ To add your data most efficiently, create a new connection to the working folder on your 

computer. In the ArcGIS Catalog pane, right-click on Folders and select Add Folder 
Connection. Browse through your computer files to your working folder. You shouldn’t see 
any data inside, as this is only looking for folders to connect. Select OK, and you should see 
your working folder appear in the folders list. If not, right-click Folders and select Refresh. 

 

PART B: Spatial Data and Attribute Joins 

 
1.​ Add Data to the Project 

 
a.​ From the Catalog, open your working folder and find the Intro_GIS_Tutorial_Data folder. 

Expand it to see the contents.  
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b.​ The two .shp datasets (NH_CensusTracts and VT_Census Tracts) are called “Shapefiles”, a 
specific format of spatial data used by ArcGIS. Add them to your project by either clicking 
and dragging into the Canvas, or right-click their name → Add to Map. 
 

c.​ You should now see data for New Hampshire and Vermont added to your map. They will be 
a default random color, which we can update later. Are these shapefiles vector or raster 
data? How can you tell? 

 
d.​ While each shapefile looks like an individual file within ArcGIS Pro, this is not the case on 

your computer’s hard drive. Outside of ArcGIS, open your file explorer and browse to your 
working folder. Examine the contents of the Intro_GIS_Tutorial_Data folder. How many files 
actually make up each shapefile? 

 
Shapefiles typically have 3-8 different file components, which each serve a different purpose 
(e.g. .dbf stores attribute information, .prj stores coordinate system information, .shp stores 
geometry). All of these files are necessary for ArcGIS to read it as one dataset. If you need to 
send someone data in the future, you must share all the files together.   

 
2.​ Explore the Map Contents 

 
a.​ In your Contents pane at left, you should see the two shapefile 

names at the top. Layers are shown on the map canvas based on 
their drawing order, which automatically shows items at the top 
above items on the bottom. Do you notice any changes if you 
click and drag the shapefiles into a different order? 
 

b.​ Towards the bottom of the Map, you should see a number of 
layers for your basemap. The number and name depends on 
which basemap you choose. Uncheck the box next to each layer 
to see what it does. If you ever want to hide place labels or only 
show labels, you can always turn these on and off. 

 
c.​ Click and drag your basemap land layer to the top of the 

Contents pane. What happens to the data? Place it back at the 
bottom of Contents.  

 
3.​ Examine Attribute Information 

 
Remember that there are two components to geospatial data: spatial and attribute. You can see 
the spatial component on the map canvas, but you can also examine their attributes.  

a.​ Right-click one of the census tract layers and select Attribute Table. In the bottom table, you 
can see records (rows) for each polygon displayed on the map.  
 

b.​ Use the slider bar at the bottom to look through the fields (columns). What information do 
you see in the attribute table? Is there anything we can use to create a meaningful map? 
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The census tract shapefiles contain fields with ID values and random values, but no population or 
demographic information. To add relevant information, we will need to use the relational 
database aspect of GIS by joining the shapefile’s attribute table to the two external tables. This is 
very common for Census data, which will often require joining many tables together. 

4.​ Assess Data Types 
 

a.​ Make sure the two CSV tables for NH and VT are added to 
your project. They will not be visible on the map, as they do 
not have coordinates, but they should be listed in the 
Contents under Standalone Tables.  
 

b.​ Right-click the NH CSV name and Open. In the table, you should see a field named 
‘GEOID’, which contains the ID number of each tract polygon, along with other fields 
describing the total number of households in each tract, and total number of households using 
the Supplemental Nutrition Assistance Program (SNAP).  

 
c.​ Compare the NH CSV table to the attribute table of the NH shapefile. To join them, you will 

need to find a field with identical values within both tables to use as the linking key. The 
fields can have different names, but the values should be the same. Which common field will 
you use as the linking key? 

 
d.​ Choose one of the NH attribute tables, then hover your cursor 

over the linking key field until a message box pops up. What is 
the type (data type) listed?  

 
e.​ Check the data type for the linking key in the other NH data. 

Are they both the same? Write down the types to remember 
them.  
 

f.​ Do the same for the VT CSV and VT shapefile. Do the VT 
linking keys have the same data type, or different? 

 
g.​ Test out what would happen if you joined tables together with different data types: right-click 

on the NH shapefile’s name in Contents and go to Joins and Relates → Add Join. The input 
table should be the shapefile, and the join table NH_SNAP_Assistance.csv. Leave the Input 
and Join fields as GEOID and select OK.   

 
h.​ Check the attribute table for the NH shapefile and scroll all the way to the right. You should 

see new fields added from the joined table. Did the join work successfully? 
 

i.​ Because the linking keys had different data types, the join did not work and produced all null 
values. You will need to remove this join by right-clicking on the shapefile name in Contents 
→ Join and Relates → Remove all Joins.  
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5.​ Update Field Data Types 
 

a.​ In order to join the datasets successfully, you will need 
to add a new field with the proper data type and copy 
GEOID into it. In the attribute table for the NH 
shapefile, click the Add Field button. Add a new field to 
the table called ID and make sure it is the data type 
Double (decimal). 
 
Note: we add a new field instead of simply changing the data type of the existing GEOID 
field because once a field has been created and saved in ArcGIS Pro, its data type cannot be 
edited. 

 

b.​ Click on the Save Edits button on the upper ribbon, then close the Fields window.  
 

 

 

 
c.​ Scroll all the way to the right of the NH census tracts attribute table. You should see the new 

field at the very end, filled with 0s. Right-click on the field name and select Calculate Field. 
 

d.​ This will open the Field Calculator, which 
calculates all values within a field 
simultaneously. You can use it to apply many 
different equations to the data, but we will 
simply copy values over from one field to 
another.  

 
e.​ To copy values from another field, scroll down 

in the list under Fields until you see GEOID. 
Double-click on the name GEOID. This should 
cause the textbox under the menu, beneath “ID 
=” to be filled with !GEOID!. The exclamation 
points tell the computer to read this as a field 
name from the dataset. Click OK. This field 
should now be populated with values.  

 
f.​ Repeat the same steps to make a new field in 

the VT census tract shapefile with the data type 
‘Double’ and copy over GEOID values. 

 
g.​ There is one other potential issue with joining 

the data. In the CSV attribute table, you may 
notice that the GEOID has a data type called 
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“Big Integer”. This is a particular type of data that can store integer values that are longer 
than ten digits. While ArcGIS can display this, it cannot actually create or edit this amount of 
data.  
 
How might you fix this? Based on the last steps, you might consider adding a new field to the 
table and copying over the values as another data type like double. But CSVs cannot be 
edited in ArcGIS (note that the add field button is greyed out).  
 

h.​ Instead, you can export the table into a 
new format, while simultaneously 
updating the field. Right-click on the 
CSV name and go to Data → Export 
Table. Use the folder icon to set a 
location on the computer to save the 
new table. For this tutorial, we will 
use your working folder, but you could 
also use the geodatabase. 
 

i.​ In the box next to Name, give it a 
reasonable name that will make sense 
to you, like NH_SNAP_Edited. Click 
OK. You should see the output table is now 
listed as a .dbf file, which is the native table 
format for ArcGIS.  

 
j.​ Before running the tool, expand the arrow 

next to Fields and select Edit.  
 

k.​ In the following window, you should see 
properties for the GEOID field. Use the 
dropdown to change the data type from Big 
Integer to Double.  

 
l.​ Do the same to update the GEOID field 
with Double data type for the other CSV 
table.  
 
6.​ Join the Shapefiles and Tables 
 
a.​ Once the data are ready, join the edited 
NH SNAP assistance table to the NH 
census tract shapefile. You will always 
want to start joins from the data you want 
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the final product to resemble (e.g. the shapefile, as it has polygons that can be mapped, unlike 
the table). Right-click the shapefile name in Contents→ Joins and Relates → Add Join). Use 
ID as the input field, and GEOID as the join field.  
 

b.​ Ignore warnings about indexing and click the 
Validate Join button. If the join will work, it 
should say something like the screenshot at 
right:  

 
c.​ Check the attribute table for the NH shapefile 

to make sure that the join succeeded. Then 
repeat the same process to join the edited VT 
table to the VT shapefile.  

 
7.​ Make the Attribute Joins Permanent 

 
Now that you have successfully joined tables to both your shapefiles, you will need to make the 
join permanent. ArcGIS temporarily joins the data together within its interface, but the 
underlying files are still separate on your computer’s hard drive (the shapefile +.dbf table). If you 
close the program, they will become unlinked. 

8.​ Right-click on the NH census tract shapefiles and go to Data → Export Features. Give it a 
name like NH_Census_Join and save it into your working folder. 
 

9.​ Repeat the same process on the VT census tract shapefile. When finished, remove the 
original layers and tables so you are only left with the joined shapefiles (right-click the 
layer’s name in Contents and Remove).  

 
PART B: Coordinate Systems and Projection 

If you have a keen geographic eye, you may have noticed that your VT and NH shapefiles look 
quite stretched and fat on the map. This is because they are currently in an unprojected 
geographic coordinate system, which the computer plots as X and Y cartesian coordinates. As a 
result, data looks quite distorted. 

There are two places to look for coordinate systems in your ArcGIS project. The map (container 
that visualizes spatial data), and the spatial data themselves (files on your hard drive). You will 
need to update both categories to a projected system. 

1.​ Update Map Coordinate System 
 

Updating the map’s coordinate system is very easy, since it doesn’t require the computer to write 
out new data files with calculated coordinates. You can do this simply in the map’s properties. 

a.​ Right-click on Map in your Contents pane and go to Properties → Coordinate Systems.  
b.​ Under ‘Current XY’ you should see the map’s coordinate system, which ArcGIS Pro 

automatically sets based on the coordinate system of the first data added to the project. What 
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coordinate system is the map currently in? Is this a geographic or projected coordinate 
system? 
 

c.​ For this tutorial, you will use the projected coordinate system NAD 1983 (2011) UTM Zone 
19N, which has minimal distortion of Vermont. For other locations, you might look up which 
projected coordinate system is commonly used by local or state governments.   

 
You could type this whole name into the search bar, but coordinate systems also have unique 
ID numbers assigned by the European Petroleum Survey Group (EPSG) and adopted as a 
current standard. Our projection is EPSG: 6348. Type ‘6348’ into the search bar and hit 
enter; you should see its name appear under Projected Coordinate System. Select the name 
and click OK. 
 

 
 

d.​ Your map should change in shape, reducing the distortion on both states. It may also rotate 
slightly to keep the study area in the middle of the map. This means that our map is now 
projected into a two-dimensional coordinate system.  

 

2.​ Exploring Projection on the Fly 
 

a.​ Open the map properties → Coordinate Systems again and expand the Layers heading. Here, 
ArcGIS lists the coordinate systems that your data layers are in. The basemap will always be 
in the Web Mercator projection, as it is a tiled image layer produced by Esri and stored in the 
cloud. What is the coordinate system of your shapefiles? 

 
e.​ Even though your map is now in NAD 1983 UTM Zone 19N, and looks undistorted, your 

data files are still in NAD 1983. This is a process called projection on the fly— your 
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computer noticed a discrepancy between your map and data and performs temporary 
calculations to align the different coordinate systems. Note that this doesn’t actually change 
the coordinates themselves, but makes them visually appear to be in the UTM projection. 
 
Test your understanding: What might happen if you calculated the area of each census tract 
polygons while the coordinate system is NAD 1983? What would be the unit of these areas? 
 

3.​ Update Coordinates into the Projected Coordinate System 
 

To change the data layers into a projected coordinate system, you cannot just open 
their properties and click on the other system. You will need to actually 
mathematically transform the coordinates using a tool called Project. 

a.​ Go to the Analysis tab → Tools icon. This opens the Geoprocessing pane at right, 
which contains all the different tools of ArcGIS. Search for “Project”, a tool which 
will mathematically transform your coordinates from one coordinate system to another. Click 
once on the tool name to open it. 
 

b.​ In the tool window, set the input dataset to be NH_CensusTracts_Join, or whatever you 
named the permanently joined layer. Save the output dataset into your folder by clicking on 
the folder icon and browsing to its location, then name it something like 
NH_CensusTracts_Projected. The output coordinate system can be set to current map, which 
should be UTM Zone 19N. Run the tool. 
 

c.​ Check that this worked: you will not see a visible difference on the map, but if you open the 
map’s properties and expand the Layers heading, it should now be in the correct coordinate 
system.  
 

d.​ Repeat the same process to project the joined VT census tract shapefile. Remove the old 
layers so you are left with only the projected versions.  

 
PART C: Create a Map  

Now that the data layers have all necessary attribute information and are in a projected 
coordinate system, you can make a map visualizing utilization of nutritional assistance programs 
across the states.  

1.​ Update Data Symbology 
 

a.​ First, you may want to change how the shapefiles are symbolized. Right-click on 
NH_CensusTracts_Projected and go to Symbology. The primary symbology defaults to 
single symbol, which will display all polygons with the same color and outline. Change this 
dropdown menu to say Graduated Colors, also known as a choropleth map. This will display 
values from a specified field, which we will want to be SNAP_Hshld, or the total count of 
households using SNAP. Change the dropdown menu next to Field accordingly.   
 

b.​ Note the spatial pattern of nutritional assistance in New Hampshire— which areas have the 
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highest number of households on SNAP?  
 

c.​ Often, a raw count of households can just show population 
distribution rather than a meaningful trend, as more people 
typically leads to more nutritional assistance. You can 
account for this by normalizing the data, or dividing it by 
the total number of households so that it becomes a rate. 
While you could do this by adding a new field to the 
attribute table and calculating it, you can also do this 
on-the-fly using an Arcade expression, which is ArcGIS’s 
native programming language. 

 
d.​ Click on the green x box next to Field, then type in the 

following expression to divide the SNAP household field 
by the total household field, symbolizing households using 
SNAP as a percentage.  

 
($feature.SNAP_Hshld/$feature.Ttl_Hshlds)*100 

 
e.​ Aside from just showing population trends, what other 

potential issues might arise from using choropleth 
symbology (graduated colors) on raw counts? 
 
Variation in the sizes of polygons can also be problematic: census tracts in rural areas tend to 
be larger than those in urban areas. This can influence people’s perceptions of spatial trends, 
as it seems like the larger areas are more important, even though the smaller census tracts 
usually have more population. We usually show raw counts (total population, etc.) as 
graduated symbols (below, left) rather than graduated color (below, right).  
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f.​ Click on the Histogram tab at the bottom to see a distribution of values within the field. You 
can change how the data are classified by switching the Method from Natural Breaks to 
something else— read through the descriptions to see what the differences are. You can also 
change the number of classes to get more or less variation (usually 4-8 is a reasonable 
number), or switch the color scheme. 
 

g.​ You can manually edit the class breaks by double-clicking into the upper value boxes under 
the Classes tab. You should also double-click into the label boxes and change to be 
percentages (e.g. type in “38 – 63%”, rather than 0.38 – 0.63).  

 
h.​ Once you are satisfied with the symbology for 

the NH layer, you should update the VT layer to 
match (this way, you can just use one legend that 
is interpreted for both states). Open the 
symbology for the VT layer, then click on the 
three lines at the upper right corner and Import 
symbology. Leave the input as VT, change 
Symbology Layer to NH, and run the tool.  

 
 

2.​ Create a Simple Map 
 

To showcase your findings, you will create a simple map layout. This allows you to add text for 
titles and legends, and to export as a PDF or image.  

 
a.​ Go to the Insert tab → New Layout. Choose a paper size that seems appropriate (8.5”x11” or 

11”x17” are common choices, either landscape or portrait).  
 

b.​ A layout window will open with a blank sheet of paper. Only things in the white paper space 
will be exported, so make sure you don’t place anything beyond its boundaries.  

 
c.​ In the Insert tab, click on Map Frame, then select the image of the map that matches what 

you just created. Click and drag to add it to your layout, like drawing a text box.  
 

d.​ Add a legend by going to the Insert tab → Legend and picking any one of the options. Click 
and drag to draw it on your layout. It usually looks quite chaotic! We can clean it up by 
renaming the layers. This will not change the underlying data file, just how it is symbolized 
in the project.  

 
e.​ Leave the layout tab and go back into your project’s map. In 

Contents, right-click on one of your NH or VT shapefiles and go to 
Properties → General. Change the name to something like “Percentage of Households 
Utilizing SNAP”.  

 
f.​ Go back to the Layout tab. At the top of the Contents pane, 

under Legend, uncheck the boxes for every layer that is not 
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the one you just edited so that there is only one item in the legend.  
 

g.​ You can remove the “Legend” title, since it’s intuitive for viewers to interpret. In the 
Contents pane, right-click on Legend and go to Properties. Under the map frame dropdown, 
uncheck the box next to Title: Show.  

 
h.​ To remove extra ‘custom’ heading in the legend, click on the 

Show Properties box, and uncheck the box next to Headings (if 
grayed out, make sure only that one layer is selected in the legend 
Contents pane).  

 
i.​ Add a title to the map by clicking on the Insert tab, then in the 

Graphics and Text group, click on  . Click and drag to draw the 
textbox. Type in some title that explains what this map shows and the study area (the what 
and where). Once placed, click on the new tab Text in the upper ribbon. Change the size to 
something reasonable. 

 
You should also update the font in your map to make it look more intentional and 
professional. To make your life easier, you might also change the entire font settings for the 
project so it will update on all future maps. Save your project, then go to the Project tab → 
Options → Text and Graphics and change the default font name to something you like better 
(good choices might be Arial, Avenir, Bell MT, whatever looks easy to read and 
professional.). Then click the back arrow at the upper left. You may need to save, close, and 
reopen the project for the change to actually apply. 

 
j.​ Add a scale bar by going to the Insert tab, clicking on the scale bar button and selecting 
an option (scale bars should not be too fancy and distracting from the rest of the map). Click 
and drag to place it where it won’t be the center of attention. Adjust the scale bar size by 
clicking and dragging the diagonal corners to make the numbers easy to read and with 
logical breaks (e.g., 10 miles rather than 13.482 miles).  

 
 

3.​ Export your Map 
 
Finally, you can export your map as either a PDF or image. PDF is a vector format that maintains 
scalability, while images will be capped at a certain resolution. We recommend a minimum 
resolution of 300 dpi if exporting an image. 

a.​ Go to the Share tab → Output Group → Export Layout button. Select the Vector PDF option. 
This should open an export window at right. Make sure the name is set to save into your 
overall working folder and name it something you will recognize.  

 

 

Conclusion 



Department of Geography​ ​ Page: 16/16 
 

You have now successfully completed the Introduction to GIS Software tutorial! To explore 
more advanced analysis sections, check out the Introduction to Vector Analysis and Introduction 
to Raster Analysis tutorials on the GIS Learning Hub. Feel free to reach out to 
aletha.e.spang@dartmouth.edu for any questions.  

mailto:aletha.e.spang@dartmouth.edu

