
STANDARD OPERATING PROCEDURES  

Drone Camera Calibration 

I. General 

Commercially available drones attached with cameras can be used to replace tripod-mounted 

cameras as a significant improvement to the photographic measurement protocol developed for 

the street lighting audit. It is worthwhile to establish standard procedures so that such technique 

can be implemented on a regular basis. Due to the differences inherited in various camera 

performances and settings, the camera needs to be calibrated first before field measurement to 

ensure accuracy. This standard operating procedure is developed to provide instructions on how 

to calibrate the Zenmuse X5S™ camera mounted on the DJI Inspire™ 2 drone for the application 

of field measurement of illumination levels at intersections. The same procedure has previously 

been conducted to calibrate the Canon EOS Rebel T3® camera and the measurement error range 

was proven to be less than ± 4%.  

II. Methodology Overview 

To calibrate the Zenmus X5S™ camera, a set of monochromatic images with different levels of 

scene illumination will be taken, and pixel information will be extracted through image analysis 

to convert into scene luminance. Then a luminance meter and illuminance meter will be used to 

measure the scene illumination level to serve as a standard, and the measured results of the Zenmus 

X5S ™ camera will be calibrated against the standard.  

III. Required Equipment 

The following equipment will be required as a minimum to conduct this calibration procedure: 

• The DJI Inspire™ 2 drone attached with Zenmuse X5S™ camera 

• Fully charged Intelligent Flight Batteries for the drone 



• A 4GB SD card for storing captured scene images 

• An Extech-HD450® illuminance meter 

• A Gossen Starlight2® luminance meter 

• An extra 9V battery for illuminance meter 

• A dimmable lamp 

IV. Drone Camera Calibration Procedures 

A. Identification of Scenes with Different Illumination Levels 

Step 1: Find a room without any natural lighting, define a rectangular area on a flat surface using 

tape. This is to ensure that the pixel information will always be analyzed within the exact same 

area so that for the subsequent image analysis, the illumination level changes of the provided 

lighting source are the only variable that will influence the measured results. 

Step 2: Once the scene area to be measured is determined, a dimmable lamp is placed in front of 

the area at a distance. This lamp will serve as the only lighting source for the camera calibration 

process. 

Step 3: Adjust the output levels of the dimmable lamp from the brightest to the darkest until 

completely turned off to obtain different scene illumination levels. It is up to users’ choice of the 

number of illumination levels to be tested. Figure 1 shows an example of one selected scene under 

different illumination levels. 

 



 

Figure 1. Scenes with Different Illumination Levels 

Step 4: For each illumination level, use the luminance meter to measure the luminance values of 

the defined rectangular scene. Record the measured values for the subsequent calibration. 

Additionally, an illuminance meter will also be used to monitor incident light output from the 

dimmable lamp. This helps to confirm that the data collection is done under constant luminance 

and any variation in the measured pixel intensities of different target images is only influenced by 

the camera’s exposure settings or source luminance instead of voltage fluctuations. 

B. Zenmuse X5S™ Camera Settings for Image Shooting 

DJI provides the DJI GOTM 4 app to control the drone and the attached camera through a mobile 

device connected to the drone’s remote controller. After the mobile device has been successfully 

connected to the remote controller, the touch screen of the mobile device can be used to record 

videos, capture photos, and set professional photography configurations. Figure 2 shows the user 

interface of the DJI GO™ 4 app. To activate still image capturing and video recording functions, 

users need to first insert a supported Micro SD card into the drone (DJI Inspire™ 2). Once the 

image capturing function is activated, the drone camera settings should be set based on the 

recommended values provide below. 



 

Figure 2. User Interface of the DJI GO™ 4 App 

• Shutter/Record Switch: Tap the shutter/record switch ([6] in Figure 2) and select shutter. To take a 

picture tap the shutter/record button ([8] in Figure 2). 

• Shooting Mode: The default mode of the drone camera is set to be Single Shooting Mode and this 

mode will also be used for camera calibration. If the shooting mode has been changed, it can be reset 

by tapping the photo configurations menu ([10] in Figure 2), then choosing sub menus in the following 

order: Settings → Video/Photo Setting → Photo.  

• Exposure Mode: The exposure mode must be set to Manual. This can be done by tapping the photo 

configurations menu ([10] in Figure 2) and then choosing sub menus in the following order: 

. This will allow aperture, shutter speed, and ISO to be set manually based on field 

conditions. 

• Shutter Speed: This will vary based on the user-selected ISO sensitivity. Each ISO sensitivity has a 

different calibration curve and a fixed exposure time that must be used. The possible shutter speed 

values for images range from 8s to 1/8000s. 



• Aperture: This can very between the recommended f-stops for the selected ISO. The maximum 

aperture is F1.7 and the minimum is F16. 

• ISO: This can be set at 3200, 6400,12800, or 25,600 depending on users’ data collection needs. The 

possible ISO values for images range from 100 to 25,600. 

• Photo Style: This should be set to Standard. 

• Photo Color: Photo color should be set to Black and White. 

• White Balance: This should always be set to automatic white balance (AWB).  

• Image Format: The images should be taken in (.DNG) format. DNG format is a generic, and highly 

compatible format developed by Adobe. It offers the advantage of smaller file sizes without loss of 

data and a universal format that is independent of manufacturer or camera-specific software. 

• Any other settings meant to enhance the images taken by the camera should be turned off. Some of 

these include ‘Exposure compensation / AEB settings’, ‘Lighting optimizer’, etc. 

• The camera must be set to Spot Metering instead of Spot Focusing. 

C. Image Shooting Process 

Step 1: Power on the DJI Inspire™ 2 drone and unlock the Travel Mode to switch the drone into 

Landing Mode by pressing the drone power button a minimum of five times. Mount the Zenmuse 

Camera to the drone gimbal, as shown in Figure 3. 

 

Figure 3. Zenmuse X5S™ Mounted to the Drone 



Step 2: Place the drone at a table in front of the defined rectangular scene area, tilt the gimbal by 

scrolling the left dial of the remote controller to adjust the camera’s field of view so that the defined 

scene area is centered in the camera view. 

Step 3: For each scene with different illumination levels, change the ISO values to 3200, 6400, 

12800, or 25,600 respectively depending on users’ data collection needs. For each ISO sensitivity, 

select different levels of aperture ranging from F1.7 to F16.  

Step 4: For each combination of ISO, aperture, and shutter speed, tap the shutter/record button ([8] 

in Figure 2) to take a photo. For each captured image, record the camera’s current settings 

including the shutter speed, aperture, and ISO values. 

D. Pixel Information Extraction 

To extract pixel intensity information from the captured images, an image analysis software 

ImageJ® is used and a script is developed accordingly to automatically extract the minimum, 

average, and maximum pixel intensity from the defined scene area in each image.  

Step 1: Convert all the captured images into the lossless TIFF format and put them along with the 

developed script in the same folder.  

Step 2: Open the ImageJ® software, and the initial interface is demonstrated in Figure 4.  

 

Figure 4. User Interface of ImageJ® 

Click ‘Plugins -> Macros -> Edit’ to open the script in a separate window. Then click ‘Plugins -> 

Macros -> Record’ to open the Recorder window. Keep these two windows open during the entire 

image analysis process. 

Step 3: Open the first image in ImageJ® by clicking ‘File -> Open’ and selecte the image. In the 

toolbar, select the ‘Polygon selection’ function as shown in Figure 5. 



 

Figure 5. Select ‘Polygon’ Function in the Toolbar 

On the selected image, draw a polygon with the same shape of the defined scene area, similar to 

the one highlighted in yellow in Figure 6. 

 

Figure 6. Draw A Polygon in the Selected Image 

Step 4: After the polygon is drawn, switch to the Recorder window, find the according coordinates 

of each drawn polygon’s corner in the brackets of the ‘makePolygon’ function, as underscored in 

Figure 7.  



 

Figure 7. Coordinates of Each Polygon’s Corner in the Recorder Window 

Copy all the coordinates and paste them into the developed script to replace the values of the 

‘makePolygon’ function (underscored in Figure 8). Additionally, change the number in the ‘for 

loop’ condition (marked in Figure 8) based on the number of actual images that users intend to 

analyze.  

 

Figure 8. Replace the Underscored Numbers with Copied Coordinates in the Script 

Step 5: Ensure the current window is the script edit window, run the script by clicking ‘Macros -> 

Run Macro’. The analysis results will be displayed in a separate window named as Results. Users 

can export the extracted pixel results into csv files and save the files to a local folder. 

It should be noted that because the position of the drone camera hasn’t been changed during the 

image shooting process, the defined scene area will always be in the same location within the 

camera’s field of view, thus the same polygon can be applied to every captured image for pixel 

extraction. However, if the position of the camera has been changed, then users will need to draw 

new polygons manually for images with a different field of view, and repeat the above process. 



E. Dark Current Estimation 

Step 1: After the image shooting process, keep all the equipment at the same place, turn off the 

lamp completely. 

Step 2: For each ISO sensitivity selected in the image shooting process, take another set of images 

with different aperture settings. 

Step 3: Conduct the pixel information extraction process on the captured images, and record the 

mean pixel intensity of each image. Obtain the dark current for each ISO value by calculating the 

median of the images’ mean pixel intensity. 

F. Camera Calibration Process 

To calibrate the camera, a relationship between the measured pixel intensity and actual scene 

luminance should be established. Previous studies have found that the relationship between pixel 

intensity and scene luminance can be simplified into a linear equation, as shown in Equation 1. 

The term ‘RHS’ can be defined as the interaction of scene luminance and camera’s exposure 

parameters, which equals to the product of shutter speed (t) and ISO sensitivity (S) and scene 

luminance (Ls), divided by the square of the aperture number (fs
2). K is a constant that will be 

calibrated for the drone camera.  

𝑁𝑑 = (
𝑡𝑆

𝑓𝑆
2 𝐿𝑠) 𝐾 … =  (𝑅𝐻𝑆)𝐾 

Equation 1. Relationship between Pixel Intensity and Scene Luminance 

Step 1: For each analyzed image, subtract the estimated dark current from the measured mean pixel 

intensity to obtain the adjusted pixel intensity. Then input the adjusted pixel intensity into Equation 

1 to calculate RHS. 

Step 2: Plot the extracted mean pixel intensity against the calculated RHS based on the collected 

data for each ISO sensitivity. Figure 9 shows an example of the plot made during a previous study. 

The plot is based on data collected at scene luminance of 54.4, 2.94, 1.28, 1.2, 0.26, and 0.24 cd/m2 

with the Starlight2®. 



 

Figure 9. Example of Mean Pixel Intensity vs. RHS Plot 

Step 3: Because the initial fitting of the data doesn’t quite suggest a linear relationship between 

the mean pixel intensity and RHS in the selected linear response range, the original RHS values 

are transformed by natural log fitting. 

Step 4: Plot the extracted mean pixel intensity against the natural log transformed RHS, as shown 

in Figure 10. Conduct linear regression on the processed data to obtain the value constant K of 

Equation 1, and the mathematical relationship between mean pixel intensity and scene luminance 

is established.  



 

Figure 10. Example of Mean Pixel Intensity vs. Log Transformed RHS Plot 

For subsequent scene illumination level measurement, simply use the calibrated camera to capture 

images of the interested scene, and analyze the captured images to extract the mean pixel intensity, 

then use the calibrated equation to convert the pixel information into the measured scene 

luminance. 

  



Procedure Checklist of Drone Camera Calibration 

Procedure Checklist of Drone Camera Calibration 

General Information 

Project Number: Comments 

Date: 

  Time: 

Recorder: 

Required Equipment Check 

Drone Camera 

Calibration Equipment 

DJI INSPIRE™ 2 Drone attached with Zenmuse X5S™ camera   

A set of fully charged Intelligent Flight Batteries   

A 4GB SD card for storing captured scene images   

An Extech-HD450® illuminance meter   

A Gossen Starlight2® luminance meter   

An extra 9V battery for illuminance meter   

A dimmable lamp   

A mobile device with DJI GO™ 4 app installed   

Drone Camera Calibration Check 

Identification of Scenes 

with Different 

Illumination Levels 

Find a room without any natural lighting, define a rectangular area on a 

flat surface using tape 
  

Place a dimmable lamp in front of the defined area at a distance   

Adjust the output levels of the dimmable lamp from the brightest to the 

darkest until completely turned off to obtain different scene illumination 

levels based on project needs 

  

Use the luminance meter to measure the luminance values of the defined 

rectangular scene for each illumination level and record the measured 

values  

  

Adjust Zenmuse X5S™ 

Camera Settings for 

Image Shooting 

Connect the mobile device with DJI GO 4 app installed to the drone 

remote controller 
  

Tap the shutter/record switch button in the DJI GO 4 app and select 

shutter, then tap the shutter/record button again to take a picture 
  

Use the default 'Single Shooting Mode' of the drone camera    

Set the exposure mode to be Manual   

Set photo style to be Standard   

Set photo color to be Black and White   



Set white balance to be automatic white balance (AWB)   

The images should be taken in (.DNG) format   

Any other settings meant to enhance the images taken by the camera 

should be turned off 
  

Set the camera to be Spot Metering    

Image shooting 

Power on the DJI Inspire™ 2 drone and unlock the Travel Mode to 

switch the drone into Landing Mode by pressing the drone power button 

a minimum of five times 

  

Mount the  Zenmuse X5S™ Camera to the drone gimbal   

Place the drone at a table in front of the defined rectangular scene area, 

tilt the gimbal by scrolling the left dial of the remote controller to adjust 

the camera’s field of view so that the defined scene area is centered in 

the camera view 

  

For each scene with different illumination levels, change the ISO values 

to 3200, 6400, 12800, or 25,600 respectively depending on users’ data 

collection needs. For each ISO sensitivity, select different levels of 

aperture ranging from F1.7 to F16 

  

For each combination of ISO, aperture, and shutter speed, tap the 

shutter/record button to take a photo 
  

For each captured image, record the camera’s current settings including 

the shutter speed, aperture, and ISO values 
  

Extract pixel 

information 

Convert all the captured images into the lossless TIFF format and put 

them along with the developed script in the same folder 
  

Open the ImageJ® software and Click ‘Plugins -> Macros -> Edit’ to 

open the script in a separate window, then click ‘Plugins -> Macros -> 

Record’ to open the Recorder window. Keep these two windows open 

during the entire image analysis process 

  

Open the first image in ImageJ® by clicking ‘File -> Open’ and select 

the image 
  

In the toolbar, select the ‘Polygon selection’ function, and  draw a 

polygon with the same shape of the defined scene area on the selected 

image 

  

Switch to the Recorder window, find the according coordinates of each 

drawn polygon’s corner in the brackets of the ‘makePolygon’ function  
  



Copy all the coordinates and paste them into the developed script to 

replace the values of the ‘makePolygon’ function and change the 

number in the ‘for loop’ condition based on the number of actual images 

that users intend to analyze 

  

Ensure the current window is the script edit window, run the script by 

clicking ‘Macros -> Run Macro’ 
  

Export the extracted pixel results from in a separate window named as 

Results into csv files and save the files to a local folder 
  

Estimate Dark Current 

After the image shooting process, keep all the equipment at the same 

place, turn off the lamp completely 
  

For each ISO sensitivity selected in the image shooting process, take 

another set of images with different aperture settings 
  

Conduct the pixel information extraction process on the captured 

images, and record the mean pixel intensity of each image 
  

Obtain the dark current for each ISO value by calculating the median of 

the images’ mean pixel intensity 
  

Camera Calibration 

Process 

For each analyzed image, subtract the estimated dark current from the 

measured mean pixel intensity to obtain the adjusted pixel intensity 
  

Use the adjusted pixel intensity to calculate RHS and transform the RHS 

values by natural log fitting 
  

Plot the extracted mean pixel intensity against the natural log 

transformed RHS based on the collected data for each ISO sensitivity 
  

Conduct linear regression on the processed data to identify the 

mathematical relationship between mean pixel intensity and scene 

luminance 

  

Operator Signature   

 

 


