
[bookmark: _hfab4sfsnuwa]Canvas Quiz Converter Testing - SDSU & NYIT Tools (Thanks to Lauren Totino at MIT, ltotino@mit.edu)
[bookmark: _9eo50jh44tl]Quick Summary
· Both the SDSU tool and NYIT tool require far less formatting and less effort to copy text over from ChatGPT compared to the Kansas State tool, which Sam Medeiros (IS&T & Canvas team) had tested in February 2024 (see very end of doc for this email from Sheryl/Sam). 
· These two tools were recommended by a Canvas R1 Peer from UVA who had done research on text > quiz converters. The peer also mentioned Respondus and GetMarked, which MIT does not have and is not pursuing at this time. We were not able to contact a developer/maintainer of the Kansas State tool. 
· Both tools successfully support non-Roman characters throughout the process of converting a text file to QTI and when that QTI is imported to Canvas/the text becomes Quiz questions.
· The SDSU tool offers a bit more flexibility in formatting the questions, but the QTI conversion takes place on a site that is technically not “secure” (“use at own risk” is what UVA peer told me).
· Caveat for both of these tools: my testing may not capture the complexity of what Takako is trying to do. I also only tested with MC questions - I did not yet do a test of every type of supported questions type, like true/false and multiple answers (though I am happy to do further testing!). 

[bookmark: _yt3cnuurgrae]Testing the San Diego State University Canvas Quiz Converter Tool
[bookmark: _t1zh9ypuxiz1]A) Testing the Basic Quiz template/format
· Supports just questions and the correct answer - can’t indicate Question Titles or Points 
· Given this, when you upload the QTI file in Canvas, Canvas by default makes each question 1 point. It also calls the quiz “Quiz” as the default title in Canvas.
· Go with this option if you want the least amount of formatting to do in ChatGPT and in the txt file, with possibly some manual work in Canvas after the QTI has been imported.


1. I had ChatGPT generate 10 sample quiz questions in Japanese (kanji, in this example). 
· For the sake of testing, I went with multiple choice with one correct answer.
· I told it to format the questions and correct answer according to the SDSU’s Basic Quiz template, linked above.
· You can see my prompting and outputs here (and example of what it looks like below).

 
[image: ]


2. I used the copy button in ChatGPT at the end of its response containing the sample questions, and pasted it into a Word doc. 
· Since this is the Basic template, I did not do any further formatting. It copied nicely from ChatGPT.
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3. Then I followed Step 3 on the SDSU site, first saving the Word doc as a plain text file (.txt), then saving it with UTF-8 encoding (steps which the site links to, here).

4. Continuing to follow the SDSU steps, I opened up their converter tool page. I dragged and dropped the txt file into the box and it produced a zip file, saved automatically to my downloads. 
· NOTE: If you are using Chrome, you may get a warning about downloading the zip - I had to click ‘Keep’ and then it downloaded.

5. Then on one of my Canvas demo sites, I chose ‘Import Existing Content’ and selected ‘QTI .zip file’ and chose the zip that was just downloaded from the converter tool. For ‘Default Question bank,” I created a new question bank for this test.

6. After clicking ‘Import,” it finished the job pretty quickly (noting that it was only 10 questions, Takako may be doing more in bulk at a time). 

7. As the SDSU site notes, the import results in the automatic creation of BOTH a Quiz AND a Question Bank. 

Both are called “Quiz.” By default, the Quiz itself is 10 points (1 point per Q) and remains unpublished:
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The characters showed up seemingly without issue, and questions can of course be edited further on the Canvas side.[image: ]














[bookmark: _2hsexoqxlmus]B) Testing the Advanced Quiz template/format
· You can include more details up front in the txt file before converting to QTI, such as Quiz Title and points per question
· Go with this option if you want to do a little more work in ChatGPT and in your txt to format it, but you get more details in up front so less manual work in Canvas after the QTI has been imported.

1. I had ChatGPT update the format of the questions it previously generated for me in for the Basic test, above. Per the SDSU Advanced Quiz template, I had it add a Question Title and Points. (Side note: It’s interesting that ChatGPT originally put the title in English by default, and I asked it to write it in kanji). 
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2. I used the copy button in ChatGPT at the end of its response containing the updated sample questions, and pasted it into a Word doc. 
· I did end up doing some formatting in the Word doc to align it more closely to SDSU’s Advanced Quiz template - for example, removing spaces and dashes that came over to Word when I copied from ChatGPT.
· I also added a Quiz Title (in kanji), which is part of the Advanced template, and to test out that Canvas does not just call it “Quiz” after the QTI import. 










3. Then I followed Step 3 on the SDSU site, first saving the Word doc as a plain text file (.txt), then saving it with UTF-8 encoding (steps which the site links to, here)

4. Continuing to follow the SDSU steps, I opened up their converter tool page. I dragged and dropped the txt file into the box and it output a zip file, saved automatically to my downloads. 
· NOTE: If you are using Chrome, you may get a warning about downloading the zip - I had to click ‘Keep’ and then it downloaded.

5. Then on the same Canvas demo site as before, I chose ‘Import Existing Content’ and selected ‘QTI .zip file’ and chose the zip that was just downloaded from the converter tool. For ‘Default Question bank,” I created a new question bank.”

6. After clicking ‘Import,” it finished the job pretty quickly (noting that it was only 10 questions, Takako may be doing more in bulk at a time).

7. This time, the Quiz it created reflects the Quiz Name I had entered in the Advanced Template (in kanji). It also reflects the points I assigned (2 pts per Q).
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The Question Bank also reflects the name of the Quiz:
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[bookmark: _p3dr9glbji2k]Compared to Kansas State tool:
· The overall process of SDSU tool is quicker/easier because there’s far less formatting - no need to have ChatGPT make the questions into a table format because there is no CSV involved. And no further formatting to get text from ChatGPT > CSV. 
· If going the Advanced route, you will still have to do some formatting in Word before you convert it to txt and QTI, but probably still less so than preparing the CSV file. I suppose it depends on how many questions you’re having ChatGPT create for you. Still, I imagine it’s fewer clicks than manually adding questions in Canvas. 
· Note that the resulting SDSU QTI file creates both a quiz AND a question bank after you import it to Canvas. If you only want the question bank, make sure to delete/don’t publish the quiz.
· The code for the SDSU converter tool is available on github which could be a positive thing?
[bookmark: _ai8l49uca7z]
[bookmark: _d6lhnowq986s]
[bookmark: _anh541c63cii]
[bookmark: _2f3btx8tlg8q]
[bookmark: _cwwpxbhfq6l]
Testing the New York Institute of Technology Converter Tool

1. I copied the same questions from above from ChatGPT directly into the text box on the NYIT site. At first, I copied the version that ChatGPT gave me for the Advanced Template with SDSU, i.e., with a question title and points written out. I also filled out the ‘Assessment Title’ (in kanji) and points per question, which in this tool is given its own box

2. Upon clicking ‘Check for Syntax Errors’ the first time, it threw an error about too many line breaks/spacing. 
[image: ]

3. Upon fixing the line breaks/spacing and clicking ‘Check for Syntax Errors’ again, it threw an error for each question, saying it wasn’t formatted properly. I assumed this was because it had extra text from the Advanced SDSU template like “Title” and “Points.” 

[image: ]

4. As soon as I removed that extra text, and copied from ChatGPT what I had used for the SDSU Basic template, the syntax errors cleared and I was good to download. 

[image: ]


5. My Chrome did not have an issue downloading this zip/no warnings from this tool. 

6. On my Canvas demo site, I did the same steps for importing the QTI file as I did for both SDSU tests, and it all worked the same way.

7. Like SDSU, it creates both a Quiz and a Question Bank. Interestingly, the Quiz remains Unnamed, not the ‘Assessment Name’ I had in kanji:
[image: ]

But the questions themselves are in kanji, so the characters do carry over.
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The Question Bank also did not have a name:
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[bookmark: _18iwv1pg7k2n]Compared to Kansas State tool and SDSU tool:
· It’s possibly even easier than the SDSU tool, as long as you stick to its formatting (which is most similar to SDSU’s Basic template - so not ideal if trying to do anything more advanced).
· It cuts out the step of pasting from ChatGPT into Word and then saving Word as txt and encoding it further for UTF-8. You just paste from ChatGPT into the text box on the NYIT page. 
· You undoubtedly will have to do some formatting cleanup, but it helps you identify what the errors are when you click the ‘Check for Syntax Errors’ button.
· Downloading the zip and importing it into Canvas works the exact same as SDSU, creating both a Quiz and a Question Bank, though I don’t know why in my test it did not retain the Assessment Title as the Quiz Title (probably because it was in kanji?). So SDSU has a slight advantage over NYIT in this department.





[bookmark: _b45eara80zt8]Appendix: Sam’s work in January/February 2024 to use the Kansas State tool to copy from Chat GPT into Canvas Quiz
**Note: This testing was done before it was figured out that Unicode (needed for Japanese) is not supported.

What ChatGPT generates is very ill-formatted for importing into Excel in the right way to generate the CSV, and there are some other gotchas I found too. These issues (formatting or exporting the wrong type of CSV) can cause errors. Here is exactly what I did, which worked for me:
1. Use the sample ChatGPT prompt on the Canvas Community page Takako provided to generate some sample questions in ChatGPT.
2. Copy what ChatGPT generated, starting from the third row. The first row is column headers (Type, Points, etc.) and the second row is a dotted line in plain text. This is what this looks like in ChatGPT’s raw output: 
3. Save what I copied to a plain text file on my computer.
4. Open Excel, go to the Data tab, and click “From Text” in the Get Data menu.
5. Select the plain text file I just saved with the ChatGPT content.
6. Now Excel shows the Text Import Wizard. On the first page of the wizard, select the radio button for “Delimited” and then click Next.
7. On the second page of the wizard, select the checkbox for “Other” and enter in the text box a single character: |
· This character is used as a divider in the original ChatGPT table.
8. Click Next again, and then Finish.
9. Click Import on the next screen.
10. Now there are two more formatting tasks to complete to ensure things work correctly. First, delete the first (should be empty) column.
11. The new first column will contain a list of question type codes, such as MC. Select this column, then go to Edit > Find > Replace.
12. Next to “Find what:” enter a single space in the text box. Make sure the box next to “Replace with:” is empty. Now click Replace All to remove trailing spaces in the first column.
13. The file is now ready to save. Go to File > Save As. Select “Comma Separated Values (.csv)” under Specialty Formats and then save the file to your computer.
· Excel shows a CSV UTF-8 format under Common Formats, but this format seems to generate an error when converting to QTI.
14. Go to the Kansas State QTI conversion tool: https://canconvert.k-state.edu/qti/
15. Select the CSV file and perform conversion. Shortly, the tool will download a zip file. This is the QTI format file.
16. From here, that zip file can be imported in Canvas following the standard Canvas instructions here.
It’s rough, but the results of my successfully imported files are on this test site (both quizzes have the same set of questions): https://canvas.mit.edu/courses/9022/quizzes
As an aside, I do wish this process was not so finicky, but in my view it comes down to 1) the amount of extra characters ChatGPT inserts into its table for whatever reason, and 2) the fact that any conversion to QTI format is necessary at all. [longer term, we will push Canvas to natively accept CSV files for question imports or offer a conversion tool themselves; this will not happen quickly, if at all, but we will try].
That being said, the Kansas State conversion tool works fine, it’s just that the ChatGPT output requires extra cleanup (and one must choose the correct CSV format when saving from Excel, also).
[bookmark: _359mtqmt1s6m]
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